403 Request denied with valid access_token

This space is made available to users of Open Patent Services (OPS) web-service and now also to users of EPO’s bulk data subscription products such as 14. EPO worldwide bibliographic database (DOCDB), 14.11 EPO worldwide legal status database (INPADOC), 14.12 EP full text data, 14.1 EP bibliographic data (EBD)and more.

Users can ask each other questions, exchange experiences and solutions, post ideas. The moderator will use this space to announce changes or other relevant information.
Post Reply

scruffy
Posts: 6
Joined: Sat Jan 05, 2013 7:18 am

403 Request denied with valid access_token

Post by scruffy » Thu Apr 17, 2014 12:25 am

Hi OPS,

I am a registered OPS user with a browser-based application that uses OPS. I would like to publish my app on-line, but even though it works fine from my IP at home, I get a 403 Request Denied when I try to use it on my shared-web-hosting account (PythonAnywhere). I'm even using a valid access_token I received from the same IP. I can not afford a dedicated web-server, I just want to share my program on a shared web-host. Is there any way you can allow requests from blacklisted IPs when the access_token is valid? Otherwise it is not practical for little guys like me to share interesting things using OPS.

Thank you for your kind attention,

Anthony Glaser,
Ottawa, Canada


EPO / OPS Support
Posts: 1027
Joined: Thu Feb 22, 2007 5:32 pm

Re: 403 Request denied with valid access_token

Post by EPO / OPS Support » Thu Apr 17, 2014 7:41 am

Dear user,

Information given here is not helpful for us to assist you further. Please be so kind and write to the email address that you have from us and give us all necessary details there: your OPS UID, IP address, response from your server.... We will then try to find a solution for you.

Forum is meant for exchange of information between users of web-services and not so much for us replying individual questions which seems to be the case lately. Every registered OPS user receives at least one email from OPS where email address of the department dealing with customer support is mentioned and it is always more beneficial for you to contact us directly.

You can find more info here: http://www.epo.org/searching/free/ops.html


Kind regards,
OPS support


scruffy
Posts: 6
Joined: Sat Jan 05, 2013 7:18 am

Re: 403 Request denied with valid access_token

Post by scruffy » Thu Apr 17, 2014 3:44 pm

I had already sent that information to patentdata@epo.org, the only email I have for you, and was still waiting for a reply. This is an issue that affects multiple IP addresses, that's the point. If the OPS service is not available for websites on shared-hosts that is something that affects many potential users which is why I tried to have a public discussion.

I guess I'll go back to waiting to a reply to my e-mail.

Anthony


EPO / OPS Support
Posts: 1027
Joined: Thu Feb 22, 2007 5:32 pm

Re: 403 Request denied with valid access_token

Post by EPO / OPS Support » Tue Apr 22, 2014 8:48 am

Dear Anthony,

I have checked our Patentdata Inbox and spam filter and we never got any emails from your side. We never blacklisted any random shared-hosts just because they offer shared-web-hosting accounts, we have no reason for doing any such thing. This is why I need your information and the IP you are using to see if that IP is really blacklisted in a first place and if it is to white-list it again. You can understand that any such information about your account can only be shared on one to one basis and not over forum.

If you need our help with your issue, send us an email as requested in my first email.

Kind regards,

OPS support


scruffy
Posts: 6
Joined: Sat Jan 05, 2013 7:18 am

Re: 403 Request denied with valid access_token

Post by scruffy » Fri Apr 25, 2014 9:55 pm

My gmail sent folder shows I sent patentdata@epo.org my query on Tue, Apr 15, 2014 at 5:27 PM.

And again: my problem is that I have no way of predicting what my IP will be. Even if you fix the particular IP I had been assigned, my web-host makes no guarantees about what IP I will be assigned in the future. I don't think it's fair if you are black-listing shared IPs if I'm using a valid data token.

I will try re-sending you the email.


EPO / OPS Support
Posts: 1027
Joined: Thu Feb 22, 2007 5:32 pm

Re: 403 Request denied with valid access_token

Post by EPO / OPS Support » Mon Apr 28, 2014 8:34 am

Today we got both of your emails and I have already forwarded them to our IT so that they can have a look at it as soon as they can.

If we ever block any IP's is only when there is a question of a missus of OPS Fair Use Charter. I am sure we will find some solution for you. It's certainly not the case that we would go randomly around blocking access
to users just because they are coming from share-hosts! Behind any blocked access from our side there is always a very valid reason.

I will get back to you via email once I get some info from IT

Kind regards,
OPS support


EPO / OPS Support
Posts: 1027
Joined: Thu Feb 22, 2007 5:32 pm

Re: 403 Request denied with valid access_token

Post by EPO / OPS Support » Mon Apr 28, 2014 3:07 pm

I hope you got my email by now. You could start using OPS in about one hour from now. Let us know if it works.

Kind regards,
OPS support


Post Reply