Search found 14 matches

by jalipert
Sun Dec 01, 2019 7:20 am
Forum: Open Patent Services (OPS) and bulk data subscription products
Topic: Recent OPS outages
Replies: 1
Views: 102

Recent OPS outages

Hello OPS Team, We've noticed some recent outages w/ various OPS services beyond the normal nightly maintenance window. Are these issues expected to be resolved soon? Detected outages over the past two days: 11/29/2019: 7:33PM UTC (for 1 minute) 8:05 PM UTC (for 6 minutes) 8:41 PM UTC (for 1 minute)...
by jalipert
Mon Jul 30, 2018 2:41 am
Forum: Open Patent Services (OPS) and bulk data subscription products
Topic: How to obtain formula images in claim text?
Replies: 1
Views: 522

How to obtain formula images in claim text?

In the claim text returned from OPS, chemical formulas are often referenced with img tags and a reference number. Example EP.2236541.A1: <claim-text>1. A (optionally non-dendrim eric) polyester amide macromolecule represented by Formula 1. <img class="EMIRef" id="029338117-ib0021"/></claim-text> How...
by jalipert
Tue Jun 05, 2018 6:45 pm
Forum: Open Patent Services (OPS) and bulk data subscription products
Topic: fetching biblio in batch for ~70 - 100 patents at once doesn't return proper headers
Replies: 2
Views: 1115

Re: fetching biblio in batch for ~70 - 100 patents at once doesn't return proper headers

I wasn't able to reproduce in postman, and after further investigation it looks like an issue with PHP clients when the POST size is above 1024 bytes (which I suppose happens once the number of patents in a request gets above 70 or so). I was able to fix my issue and get the expected response header...
by jalipert
Sun Jun 03, 2018 1:33 am
Forum: Open Patent Services (OPS) and bulk data subscription products
Topic: fetching biblio in batch for ~70 - 100 patents at once doesn't return proper headers
Replies: 2
Views: 1115

fetching biblio in batch for ~70 - 100 patents at once doesn't return proper headers

Hello, The biblio API allows input for up to 100 patents in batch during a POST request. However, I've noticed that if I run a query of ~70 - 100 patents at once (easily reproducible for me when passing in 100 patents), the headers are missing info such as the Quota usage. In this case, the response...
by jalipert
Thu May 31, 2018 8:01 pm
Forum: Open Patent Services (OPS) and bulk data subscription products
Topic: OPS unavailable as of 16:11 UTC on 2018-05-31
Replies: 3
Views: 852

Re: OPS unavailable as of 16:11 UTC on 2018-05-31

it's back up now. total downtime: 2 hours, 50 minutes
by jalipert
Thu May 31, 2018 5:26 pm
Forum: Open Patent Services (OPS) and bulk data subscription products
Topic: OPS unavailable as of 16:11 UTC on 2018-05-31
Replies: 3
Views: 852

OPS unavailable as of 16:11 UTC on 2018-05-31

Unable to use any of the OPS API at this time. Is there a place for announcements of planned downtime or was this unexpected?

Thanks!
Joe
by jalipert
Wed May 09, 2018 7:25 am
Forum: Open Patent Services (OPS) and bulk data subscription products
Topic: docdb biblio - unusual behavior
Replies: 3
Views: 1126

Re: docdb biblio - unusual behavior

Code: Select all

curl -X POST \
  https://ops.epo.org/3.2/rest-services/published-data/publication/docdb/biblio \
  -H 'Authorization: Bearer MY_TOKEN_HERE' \
  -H 'Cache-Control: no-cache' \
  -H 'Content-Type: text/plain; charset=UTF-8' \
  -d 'JP.H0678863.U,JP.H088451.Y2'
by jalipert
Tue May 08, 2018 3:30 pm
Forum: Open Patent Services (OPS) and bulk data subscription products
Topic: docdb biblio - unusual behavior
Replies: 3
Views: 1126

docdb biblio - unusual behavior

Hi, I noticed some unusual behavior with the docdb biblio endpoint. If I query the following two patents together: JP.H0678863.U JP.H088451.Y2 The response opens with a status="not found" result, followed by the correct response for each of the two patents: <?xml version="1.0" encoding="UTF-8"?> <?x...
by jalipert
Sat May 05, 2018 11:16 pm
Forum: Open Patent Services (OPS) and bulk data subscription products
Topic: problem with POST request for DOCDB (that was fixed in November) is back in the current version
Replies: 1
Views: 847

problem with POST request for DOCDB (that was fixed in November) is back in the current version

EDIT: see correction below. Hello, There used to be an issue querying multiple patents at once in docdb, where if any one of the input patent numbers were not found, the entire response to the API call returns SERVER.EntityNotFound - No results found. That problem was fixed in an update back in Nov...
by jalipert
Tue Jan 16, 2018 8:21 pm
Forum: Open Patent Services (OPS) and bulk data subscription products
Topic: advice on querying DE biblio data
Replies: 1
Views: 813

advice on querying DE biblio data

Hi Vesna and team,

Do you have advice on best practice for querying biblio data for German (DE) patents?

I'm unable to find biblio data for many publications using any of the API endpoints, here are a couple examples to try:
DE60323386D1
DE50107480D1

Thanks!
Joe