DataSizeQuota limit, but usage API return nothing

This space is made available to users of Open Patent Services (OPS) web-service and now also to users of EPO’s bulk data subscription products such as 14. EPO worldwide bibliographic database (DOCDB), 14.11 EPO worldwide legal status database (INPADOC), 14.12 EP full text data, 14.1 EP bibliographic data (EBD)and more.

Users can ask each other questions, exchange experiences and solutions, post ideas. The moderator will use this space to announce changes or other relevant information.
Post Reply

lexmachina
Posts: 4
Joined: Fri Feb 14, 2014 11:57 pm

DataSizeQuota limit, but usage API return nothing

Post by lexmachina » Sat Feb 15, 2014 12:13 am

Hi,

I'm a registered user accessing the biblio/ REST api via an authenticated access_token. In all subsequent requests I include the 'Authorization': 'Bearer <access_token>' header. After a short period of time, I appear to have exceeded your Fair Use limits and then can only get the 403 response with X-Rejection-Reason: DataSizeQuota. I have the following questions:

1. Why when I access ../developers/me/stats/usage as the same authenticated user with a timeRange parameter covering the last few days I receive back only empty statistics:
{u'environments': [{u'metrics': [], u'name': u'prod'}],
u'metaData': {u'errors': [], u'failedEnvs': u'[]', u'notices': []}}

For the record I've tried retrieving usage data over several hours with nothing returned.

2. I never receive the response headers X-IndividualQuotaPerHour-Used or X-RegisteredQuotaPerWeek-Used as mentioned in the documentation (OPS_RWS_ReferenceGuide_version1210_EN.pdf)

Thanks for your help.

- Jeff


EPO / OPS Support
Posts: 1027
Joined: Thu Feb 22, 2007 5:32 pm

Re: DataSizeQuota limit, but usage API return nothing

Post by EPO / OPS Support » Sat Feb 15, 2014 5:52 pm

Dear user,

Send us your user name via Private Message (PM) in this forum. And give us you email address so that we can contact you directly.

Kind regards,

OPS support


Post Reply