Error in CQL query with date intervall pd=

This space is made available to users of Open Patent Services (OPS) web-service and now also to users of EPO’s bulk data subscription products such as 14. EPO worldwide bibliographic database (DOCDB), 14.11 EPO worldwide legal status database (INPADOC), 14.12 EP full text data, 14.1 EP bibliographic data (EBD)and more.

Users can ask each other questions, exchange experiences and solutions, post ideas. The moderator will use this space to announce changes or other relevant information.
Post Reply

thomasst
Posts: 25
Joined: Thu Sep 25, 2008 10:50 am
Location: Munich
Contact:

Error in CQL query with date intervall pd=

Post by thomasst » Thu Apr 09, 2015 12:08 pm

Dear OPS team,
since today 09/04/2015 it seems that the query syntax for a date interval has changed without any previuos announcement. In our software we have implemented a query in the publication date field "pd" for a date interval in the form:

Code: Select all

pd="20150301 20150320"
This format is also explained in the documentation of the CQL query language, chapter 4.2. CQL index catalogue and in the examples.
Since today we receive the error

Code: Select all

<fault xmlns="http://ops.epo.org">
   <code>CLIENT.InvalidDateFormat</code>
   <message>Invalid date format "2015-03-02,2015-04-01"</message>
</fault>
The only valid format for date interval seems to be now:

Code: Select all

pd within "20150301 20150320"
As we use a complex integrated syntax translator for different web pages with search forms it is not possible to implement this syntax change from one day to the next without any announcement for all our clients. Would it be possible to allow this query syntax again for a short transition time to be able to implement the other form?

Best regards,
Thomas Stiefvater


EPO / OPS Support
Posts: 1147
Joined: Thu Feb 22, 2007 5:32 pm

Re: Error in CQL query with date intervall pd=

Post by EPO / OPS Support » Fri Apr 10, 2015 10:43 am

Thank you for your feedback,

We have informed our technical team about this and are now waiting to get some response from their side. As soon as we do, I will post it here.

Regards,

OPS support


EPO / OPS Support
Posts: 1147
Joined: Thu Feb 22, 2007 5:32 pm

Re: Error in CQL query with date intervall pd=

Post by EPO / OPS Support » Wed Apr 15, 2015 10:51 am

Hi,

I was just informed that this issue will be fixed (as it was prior to this change) with the next maintenance release planed for next week. We will announce the day of the release in this forum under Announcements.

Kind regards,

OPS support


EPO / OPS Support
Posts: 1147
Joined: Thu Feb 22, 2007 5:32 pm

Re: Error in CQL query with date intervall pd=

Post by EPO / OPS Support » Mon Apr 20, 2015 12:19 pm

http://forums.epo.org/open-patent-servi ... c3007.html

Please see following announcement

Regards,
OPS support


Post Reply