Getting data via POST

This space is made available to users of Open Patent Services (OPS) web-service and now also to users of EPO’s bulk data subscription products such as 14. EPO worldwide bibliographic database (DOCDB), 14.11 EPO worldwide legal status database (INPADOC), 14.12 EP full text data, 14.1 EP bibliographic data (EBD)and more.

Users can ask each other questions, exchange experiences and solutions, post ideas. The moderator will use this space to announce changes or other relevant information.
Post Reply

joshua.staker
Posts: 3
Joined: Wed Aug 20, 2014 6:28 pm

Getting data via POST

Post by joshua.staker » Wed Aug 20, 2014 6:44 pm

I can successfully retrieve data using the restful get method, but I'd like to follow the recommendation in the documentation to use POST for bulk retrieval, and I cannot get POST to work.

I am following the example in the documentation exactly (urls had to be removed in this post due to forum restriction):

Code: Select all

 url = 'epo url as given on page 58 of the documentation'
headers = {'Accept': 'application/exchange+xml'}
data = {'Request Body': 'EP1676595'}
And the follow result (error) is retrieved:

Code: Select all

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<fault xmlns="epo url">
    <code>SERVER.EntityNotFound</code>
    <message>No results found</message>
</fault>
I have tried many different patent numbers in different combinations (epodoc vs docdb, with or without date or KC specified; sending the 'Request Body' as a header vs a param) but without success.

Any help with this matter would be greatly appreciated.


EPO / OPS Support
Posts: 1027
Joined: Thu Feb 22, 2007 5:32 pm

Re: Getting data via POST

Post by EPO / OPS Support » Thu Aug 21, 2014 9:31 am

Dear user,

Did you try Developers test portal (API Console): https://developers.epo.org/?

Try to reproduce this example using this test area.

Kind regards,

OPS support


Post Reply