HTTP 403 – FORBIDDEN (rest-services)

This space is made available to users of Open Patent Services (OPS) web-service and now also to users of EPO’s raw data subscription products such as 14.7 DOCDB - worldwide bibliographic master database, 14.11 Worldwide legal status (INPADOC), 14.12 EP full text in XML, 14.1 EBD and more.

Users can ask each other questions, exchange experiences and solutions, post ideas. The moderator will use this space to announce changes or other relevant information.
Post Reply

raulds
Posts: 3
Joined: Thu Feb 01, 2018 5:12 pm

HTTP 403 – FORBIDDEN (rest-services)

Post by raulds » Thu Feb 01, 2018 5:41 pm

Hi there,

I am constantly receiving an HTTP 403 forbidden response when performing any published-data search. Everything was working just fine for years, however since the switch to 3.2, I am missing something, however, I just cannot figure it out.

I have checked other topics relating to the authentication changes from 3.1 - 3.2 (whitespace) i.e. https://forums.epo.org/possible-issue-w ... ation-7375

However, I doubled check that I am not including any whitespace when receiving the token. I have also changed the URL for the access token to https://ops.epo.org/3.2/auth/accesstoken , however, I constantly receive the following response when performing any published data search

403 – FORBIDDEN
<error>
<code>403</code>
<message>This request has been rejected due to the violation of Fair Use
policy</message>
<moreInfo>http://www.epo.org/searching/free/espac ... </moreInfo>
</error>

I even added another App to my profile, and received the same result using the new apps Base64
Consumer Key:Consumer Secret Key

Below are two examples of the API requests I am making, obviously passing through my token.

citation search: https://ops.epo.org/3.2/rest-services/p ... DUS7000000
biblio: https://ops.epo.org/3.2/rest-services/p ... 049/biblio

As far as I am aware, simply changing my calls from 3.1 to 3.2, and making use of an encryption connection "https" it should work.

I would greatly appreciate it if you could help me resolve this matter.

Thanks in advance.


EPO / OPS Support
Posts: 955
Joined: Thu Feb 22, 2007 5:32 pm

Re: HTTP 403 – FORBIDDEN (rest-services)

Post by EPO / OPS Support » Mon Feb 05, 2018 10:55 am

Hi,

With your URL's there is really nothing wrong, somehow your autentication is not set properly and I don't really see any info here that could be of help to identify what is going wrong. But see this and check if you apply it properly: https://en.wikipedia.org/wiki/Basic_acc ... entication

Also, its wort to check your logs, so please send me to patentdata(at) epo.org your user name of your OPS account and I will see if there is anything in your logs

Regards,
OPS support


raulds
Posts: 3
Joined: Thu Feb 01, 2018 5:12 pm

Re: HTTP 403 – FORBIDDEN (rest-services)

Post by raulds » Mon Feb 05, 2018 9:48 pm

I have checked the wiki page, as far as I can see I am doing everything correctly.

I have emailed you my username for my OPS account, along with some code snippets and the token response when requesting my token, not sure if that will be of some assistance.


CTIR
Posts: 1
Joined: Tue Feb 13, 2018 11:56 pm

Re: HTTP 403 – FORBIDDEN (rest-services)

Post by CTIR » Wed Feb 14, 2018 12:08 am

I get the same difficulty Tried all combinations and they seem to be correct
Request
Response and
cURL

is this a quatoa issue or a vesrion issue ?


EPO / OPS Support
Posts: 955
Joined: Thu Feb 22, 2007 5:32 pm

Re: HTTP 403 – FORBIDDEN (rest-services)

Post by EPO / OPS Support » Wed Feb 14, 2018 8:59 am

Hi,

For such issue is best that you send an email to us (patentdata(at)epo.org) with your OPS account user names and all details needed.
Also, see Announcements, few issues were also mentioned there (like Content type...)


Regards,
OPS support


lectoip
Posts: 2
Joined: Fri Mar 02, 2018 4:09 pm

Re: HTTP 403 – FORBIDDEN (rest-services)

Post by lectoip » Sat Mar 03, 2018 4:27 pm

Dear Rauld,

Have you managed to resolve your connection problem? I am pulling my hair with this craziness of using the secret key and all that. Other APIs are much more straightforward and easier to use. It seems there are not many people who are active enough in this forum. So I am reaching out to you. Would it be possible for you to show me exactly what is the script you use to get the XML data. I am programming my software in VBA, using MSAccess..... If you would respond to this call for help, I would be so grateful.


raulds
Posts: 3
Joined: Thu Feb 01, 2018 5:12 pm

Re: HTTP 403 – FORBIDDEN (rest-services)

Post by raulds » Mon Mar 05, 2018 2:27 pm

I have managed to resolve my issue if you give me your email address I can try and help you out.


kvor
Posts: 1
Joined: Tue Mar 20, 2018 3:27 pm

Re: HTTP 403 – FORBIDDEN (rest-services)

Post by kvor » Tue Mar 20, 2018 3:31 pm

Hello,

We face exactly the same problem. Are there any hints how we could solve it?

Best regards,

Kostas


comberh
Posts: 1
Joined: Mon Apr 23, 2018 7:33 am

Re: HTTP 403 – FORBIDDEN (rest-services)

Post by comberh » Mon Apr 23, 2018 7:37 am

raulds wrote:
Mon Mar 05, 2018 2:27 pm
I have managed to resolve my issue if you give me your email address I can try and help you out.
Hi Rauld, I am facing the same issue with an app - could you perhaps share your solution or what worked for you?


Post Reply