Public Data Search containing 'ct='

This space is made available to users of Open Patent Services (OPS) web-service and now also to users of EPO’s bulk data subscription products such as 14. EPO worldwide bibliographic database (DOCDB), 14.11 EPO worldwide legal status database (INPADOC), 14.12 EP full text data, 14.1 EP bibliographic data (EBD)and more.

Users can ask each other questions, exchange experiences and solutions, post ideas. The moderator will use this space to announce changes or other relevant information.
Post Reply

mibketek
Posts: 2
Joined: Wed Nov 07, 2018 5:31 pm

Public Data Search containing 'ct='

Post by mibketek » Wed Nov 07, 2018 5:40 pm

Hello,

I'm trying to do searches with citations of a given patent and have problems with it. I tried a few things in the developers area, I don't understand:

ct = DE102012213130 or ct = WO2014016180 or ct = EP2878004 or ct = JP6120962 or ct = US9797848 or ct = US2018038810 or ct = WO2013159049 or ct = US9182362 or ct = EP2839498
- GET /3.2/rest-services/published-data/search?q=ct%20%3D%20DE102012213130%20or%20ct%20%3D%20WO2014016180%20or%20ct%20%3D%20EP2878004%20or%20ct%20%3D%20JP6120962%20or%20ct%20%3D%20US9797848%20or%20ct%20%3D%20US2018038810%20or%20ct%20%3D%20WO2013159049%20or%20ct%20%3D%20US9182362%20or%20ct%20%3D%20EP2839498 HTTP/1.1

This one works fine. However, if I remove most of the patents using only the first two (and many other combinations I've tried):

ct = DE102012213130 or ct = WO2014016180
- GET /3.2/rest-services/published-data/search?q=ct%20%3D%20DE102012213130%20or%20ct%20%3D%20WO2014016180 HTTP/1.1

It won't work, giving: HTTP/1.1 404 Not Found
Furthermore, if I would combine the first query with a publication date:

(ct = DE102012213130 or ct = WO2014016180 or ct = EP2878004 or ct = JP6120962 or ct = US9797848 or ct = US2018038810 or ct = WO2013159049 or ct = US9182362 or ct = EP2839498) and pd>=01.01.2015
- GET /3.2/rest-services/published-data/search?q=(ct%20%3D%20DE102012213130%20or%20ct%20%3D%20WO2014016180%20or%20ct%20%3D%20EP2878004%20or%20ct%20%3D%20JP6120962%20or%20ct%20%3D%20US9797848%20or%20ct%20%3D%20US2018038810%20or%20ct%20%3D%20WO2013159049%20or%20ct%20%3D%20US9182362%20or%20ct%20%3D%20EP2839498)%20and%20pd%3E%3D01.01.2015 HTTP/1.1

It also won't work anymore, giving: HTTP/1.1 404 Not Found

I'm really lost with this, any help would be greatly appreciated!


EPO / OPS Support
Posts: 1101
Joined: Thu Feb 22, 2007 5:32 pm

Re: Public Data Search containing 'ct='

Post by EPO / OPS Support » Thu Nov 08, 2018 9:48 am

Hi,

1.) Are you trying to search for "citing" - forward or "cited" backward citations?
What you are searching below is if any of your numbers have been cited in other applications, this is also the reason why your second search gives 0, not DE or WO was cited in other publications (citing references) (or we don't have such publications loaded in our database). To see citations of DE and WO document (cited references), you have to do normal search for the number in OPS Published services and with biblio constituent and then you will have citations in bibliographic data of those patents
2.) you don't need "ct=" before every number when you are anyway using brackets
3.) your publication date format is wrong, it should be 20150101

Regards,
Vesna for OPS support


mibketek
Posts: 2
Joined: Wed Nov 07, 2018 5:31 pm

Re: Public Data Search containing 'ct='

Post by mibketek » Thu Nov 08, 2018 2:09 pm

Hi,

Thank you very much for your fast answer! This helped me a lot!

I'm trying to search for patents citing the given documents. So the given error would also appear if no results are found?

Best regards,


EPO / OPS Support
Posts: 1101
Joined: Thu Feb 22, 2007 5:32 pm

Re: Public Data Search containing 'ct='

Post by EPO / OPS Support » Thu Nov 08, 2018 3:06 pm

Yes, this comes up when nothing was found. If you have a look at OPS documentation on the website you will see other error messages that could appear as well and what exactly they mean: posting.php?mode=reply&f=35&t=7889

Regards,
Vesna for OPS support


AlNard
Posts: 4
Joined: Mon Sep 21, 2020 11:21 pm

Re: Public Data Search containing 'ct='

Post by AlNard » Wed Sep 30, 2020 6:07 pm

Dear OPS support,
I encountered the same issue presented above, except for the fact that I verified the patent I was looking for (US8080791B2) in Espacenet and it returned the correct citations. In the beginning, I thought I made a mistake in my code but it seems like there is a lack of correspondence between Espacenet and OPS. I even tried the same query using the developer portal and it returned the same error 404.
Is the data loading process still ongoing? Do you have any suggestion for finding forward citations using OPS?

Thank you for any help


EPO / OPS Support
Posts: 1101
Joined: Thu Feb 22, 2007 5:32 pm

Re: Public Data Search containing 'ct='

Post by EPO / OPS Support » Wed Sep 30, 2020 8:31 pm

HI,

Are you looking for where the US B was cited in (ct) or citation's belonging to that US

Cited;
.../rest-services/published-data/publication/docdb/US8080791.B2/biblio

Citing:
.../rest-services/published-data/search/?q=ct%3DUS8080791

Since OPS is a service behind Espacenet the results should be the same. 404 error usually means that the format of the query is wrong or incomplete.

Regards,
Vesna for OPS support


Post Reply