published-data/images/ issues

This space is made available to users of Open Patent Services (OPS) web-service and now also to users of EPO’s bulk data subscription products such as 14. EPO worldwide bibliographic database (DOCDB), 14.11 EPO worldwide legal status database (INPADOC), 14.12 EP full text data, 14.1 EP bibliographic data (EBD)and more.

Users can ask each other questions, exchange experiences and solutions, post ideas. The moderator will use this space to announce changes or other relevant information.
Post Reply

afedosenko
Posts: 4
Joined: Mon Apr 23, 2018 12:38 pm

published-data/images/ issues

Post by afedosenko » Tue Jun 26, 2018 11:39 am

Hello,

When I am trying to get the images for WO2018106282, I get two different results, depending on the version of the API:
  1. http://ops.epo.org/end-of-life/rest-ser ... 282/images
    The result contains the "inquiry result" data.
  2. http://ops.epo.org/3.2/rest-services/pu ... 282/images
    I got the following result: <code>SERVER.EntityNotFound</code><message>No results found</message>
Why do different versions of API return different images results for the same number?


EPO / OPS Support
Posts: 1021
Joined: Thu Feb 22, 2007 5:32 pm

Re: published-data/images/ issues

Post by EPO / OPS Support » Tue Jun 26, 2018 12:26 pm

Hi,

The same information should be available in both versions of OPS. We have asked colleagues in charge to propagate the document into production version too.

Thank you for informing us about it and we will amend the thread once we receive info that the document is now also in 3.2 production

Regards

Vesna for OPS support


jc275
Posts: 8
Joined: Sun Jul 24, 2016 8:02 pm

Re: published-data/images/ issues

Post by jc275 » Wed Jun 27, 2018 9:30 pm

This is not an isolated error.

See also https://forums.epo.org/404-responses-fr ... uests-7647 for more examples of the same problem. Note that all the errors were identified in the results of a single search query, so I expect you can easily find many, many more examples of missing /images endpoints.

The error rate with v3.2 is alarming. I'm frustrated that v3.1 is marked 'end-of-life' because, in my view, v3.2 is nowhere near stable enough to replace it yet.

Dear EPO, this is not an issue that can be sensibly addressed on a document-by-document basis. Once the underlying causes are identified, I hope that your developers put in place extensive testing (unit tests, regression tests, etc.) so that data doesn't disappear unexpectedly in future.


EPO / OPS Support
Posts: 1021
Joined: Thu Feb 22, 2007 5:32 pm

Re: published-data/images/ issues

Post by EPO / OPS Support » Fri Jun 29, 2018 6:49 am

Dear Sir,

You don't really believe that we are waiting here for forum postings and add only documents reported by individual users, do you?

I do understand your frustration, even better then you might think. Still, we are in the end stage of migration of that data from the old database into the new one and there is nothing we can do at this point but wait for colleagues in charge to finish their work. We are talking about the migration of many millions of image data in all possible formats. We are very well aware that users need to get their data and this is the only reason why old OPS version is still available and not deactivated as planned months ago.

If the use of old OPS is not good enough for you at this point then I can only suggest that you use either commercial services or you query needed data from individual patent offices, quite a lot of them have their own web services or other possibilities to load data from their website.

I will also make sure to inform colleagues in charge of your complaint although it would be better if you address your official complaints to us via email and with your full name instead of anonymously in a forum.

Regards,
Vesna for OPS


jc275
Posts: 8
Joined: Sun Jul 24, 2016 8:02 pm

Re: published-data/images/ issues

Post by jc275 » Fri Jun 29, 2018 5:55 pm

Thank you Vesna for your helpful reply and for addressing my concerns.

I think that the discussion forum is exactly the right place to discuss these issues, because users can benefit from one another's experiences and from the EPO's previous responses to known issues.

For example, it is probably very helpful for other users to learn that you are still migrating data across to the new database, and that 3.1 is being kept online for that reason.

It may also be helpful to provide official updates about this, such as to publicly update the planned deprecation timeline to reflect that 3.1 is still more stable/complete than 3.2 at present, and to keep us informed about which parts of the 3.2 database are already stable/complete and which are not.


EPO / OPS Support
Posts: 1021
Joined: Thu Feb 22, 2007 5:32 pm

Re: published-data/images/ issues

Post by EPO / OPS Support » Mon Jul 02, 2018 10:34 am

Hi,

I will forward your concerns to the department in charge.

Regards,
Vesna for OPS


Post Reply