Question about OPS 3.2

This space is made available to users of Open Patent Services (OPS) web-service and now also to users of EPO’s bulk data subscription products such as 14. EPO worldwide bibliographic database (DOCDB), 14.11 EPO worldwide legal status database (INPADOC), 14.12 EP full text data, 14.1 EP bibliographic data (EBD)and more.

Users can ask each other questions, exchange experiences and solutions, post ideas. The moderator will use this space to announce changes or other relevant information.
Post Reply

Lukasz
Posts: 1
Joined: Sun Jun 04, 2017 10:26 am

Question about OPS 3.2

Post by Lukasz » Sun Jun 04, 2017 10:36 am

I think there is a bug in OPS api version 3.2. When i call this url http://ops.epo.org/3.2/rest-services/published-data/publication/docdb/EP1000000/biblio using C# HttpWebRequest or WebClient using proper token i recive Error java.lang.NullPointerException but when i call using same tool http://ops.epo.org/3.1/rest-services/published-data/publication/docdb/EP1000000/biblio everything is working fine.


EPO / OPS Support
Posts: 1022
Joined: Thu Feb 22, 2007 5:32 pm

Re: Question about OPS 3.2

Post by EPO / OPS Support » Mon Jun 05, 2017 6:09 pm

If the result is an error when you do that same search in API Console, v 3.2 with default autentication swiched on then there could be an issue on our end. But if you do get sucessful response there, but not when you use your token then the issue is in the way you applied your Autentication on your end. As you know 3.2 does not have anonymous access as the 3.1 has.

Please let me know,

OPS support


Post Reply