Sending Data for multiple GET request giving Parse Error

This space is made available to users of Open Patent Services (OPS) web-service and now also to users of EPO’s bulk data subscription products such as 14. EPO worldwide bibliographic database (DOCDB), 14.11 EPO worldwide legal status database (INPADOC), 14.12 EP full text data, 14.1 EP bibliographic data (EBD)and more.

Users can ask each other questions, exchange experiences and solutions, post ideas. The moderator will use this space to announce changes or other relevant information.
Post Reply

harshdeepkanhai
Posts: 2
Joined: Thu Nov 22, 2018 12:44 pm

Sending Data for multiple GET request giving Parse Error

Post by harshdeepkanhai » Tue Nov 27, 2018 12:47 pm

I made an API over the Published Data Service(PDS) and Legal Data Service(LDS). It reads from a csv list of numbers and sends a get request in a loop till we get response of every numbers in the list. It gives a formatted output of an array with the response of the numbers(I extracted only invention-title(eng), Document_no(docdb), publication_date, priority_date, country, and legal status i.e. used the legal status codes to analyze if the application is active or Dead). I made the entire logic in a GET request encapsulating the PDS and LDS both GET request and send a response of array of the required data of the numbers. But Sometime I am getting

Code: Select all

{ Error: Parse Error
[0]     at Socket.socketOnData (_http_client.js:441:20)
[0]     at Socket.emit (events.js:182:13)
[0]     at addChunk (_stream_readable.js:283:12)
[0]     at readableAddChunk (_stream_readable.js:264:11)
[0]     at Socket.Readable.push (_stream_readable.js:219:10)
[0]     at TCP.onStreamRead (internal/stream_base_commons.js:94:17) bytesParsed: 684, code: 'HPE_INVALID_CONSTANT' }
Could you explain the reason why?


EPO / OPS Support
Posts: 1021
Joined: Thu Feb 22, 2007 5:32 pm

Re: Sending Data for multiple GET request giving Parse Error

Post by EPO / OPS Support » Tue Nov 27, 2018 1:40 pm

Hi,

I cannot see from your example why you get that response. But also, we do not have legal events that would give you exact information about patents being dead or alive and we also don't have legal status reponse for every biblio loaded in our database. Also, in OPS legal you have an option to use biblio and legal constituents in the same query so no combining Publish services and Legal is not really necessarily.

In order for me to know why you sometimes get errors I need more information and if you have those then send it to me via patentdata(at) epo.org

Regards
Vesna for OPS


Post Reply