Page 1 of 1

templates and drafts do not work after updates

Posted: Mon Jul 20, 2009 4:29 pm
by lord of files
After running the San Marino update, the information in the draft we had
prepared already was deleted and the program showed the following error
message: EBL-initialized failed. form will be closed.

Also, the templates for EP1001 can no longer be used, as San Marino is not
ticked in the states list and can not be ticked anymore. With the EP1200
templates we have the same problem/error as with the drafts.

Do we really have to newly prepare all our templates after every update?

Thank you for supporting us.
The LOFteam

Re: templates and drafts do not work after updates

Posted: Mon Jul 20, 2009 4:46 pm
by twesthues
Dear LOFTeam,

unfortunately, this issue came about when assigning a read-only property to the states in order to not give users an impression that this would still be possible. We try to address this generally in the future version 5. But in the meantime, what can be done is to export the template (open as draft) - manipulate the list of designation states to also contain 'SM' in the ep-request.xml or ep-euro-pct.xml -> import these and store again as templates - this might be better than redrafting all templates.

As to the EBL-initialized error - this one is intriguing and requires some closer look at your draft - do you still have it? - can you export it to file and send me for inspection?


Re: templates and drafts do not work after updates

Posted: Wed Jul 22, 2009 11:43 am
by lord of files
Dear Thorsten,

thank you very much for your quick reply.

We did as you suggested, but when trying to open the exported file ep-request.xml
as well as the application-body.xml the below error message popped up. Do you
have an answer / a solution for this?

Die XML-Seite kann nicht angezeigt werden
Die XML-Eingabe kann nicht angezeigt werden, wenn Stylesheet verwendet wird. Beheben Sie den Fehler und klicken Sie dann auf Aktualisieren, oder wiederholen Sie den Vorgang sp├Ąter.
Die angegebene Ressource konnte nicht gefunden werden. Fehler beim Bearbeiten der Ressource 'ep-request-v1-5.dtd'. Fehler ...
<!DOCTYPE ep-request SYSTEM "ep-request-v1-5.dtd">

About the EBL-initialized problem:
Unfortunately, we already deleted the draft you suggested to send to you for inspection.
Before deleting it, we have tried to export it though but failed. Strangely, the file can
not be found in the bin anymore either, so we can not send you the file. The file seems
to be lost, but thank you anyway for offering your help.

Best regards,

Re: templates and drafts do not work after updates

Posted: Wed Jul 22, 2009 5:05 pm
by twesthues
Dear LOFteam,

when opening XML, there several options:

Opening it in IExplorer will give you the error you describe as it cannot located the DTD - but this is the wrong place anyway as IExplorer only allows you to view things (menu option View->Source would also show you the code).

A better alternative is to open the XML either in a dedicated XML editor or simply in MS Notepad - there you can view and manipulate the XML and save it as XML again.

I hope this helps.


Re: templates and drafts do not work after updates

Posted: Thu Jul 23, 2009 12:36 pm
by lord of files
Thank you, Thorsten, we successfully manipulated the xml and
then imported it.

However, this does not solve our problem with the EBL initializing
error, which occures again when reopening the file after saving the
changes and closing it, with the result that all data that were
already contained in the file disappeared, got lost or at least are not
shown anymore. This also happens when we open new files, using
templates or forms, enter data, store them as drafts and open them again.

For this reason, we don't dare manipulating the templates with regard
to SM at the moment. Moreover, it seems that we cannot use epoline
filing (1001 and 1200) at all. We think that we could solve this problem
better on the phone. Would you mind us giving you a call this afternoon,
as we have some deadlines coming up where we would need epoline filing.

Thank you!

templates and drafts - store drafts

Posted: Mon Jul 27, 2009 7:10 pm
by lord of files
Dear Thorsten,

we have given up to manipulate templates to get them to work in the
new version. We have used the EPO supplied forms and made new
templates to reduce the risk of errors. Storing a template in a certain
request will make this request available for access. Still the open error
that occurred earlier will appear from time to time, but not consistently.
It is in fact a symptom that appears at random. We tried it five times
and it worked five times. Then, the sixth try made it unavailable for
access. The San Marino issue cannot be involved, but we have some
lost confidence in making and preparing drafts. The chance of losing all
the data is too high. How can we send one of those exported files for
your review? We have an easy XP system with three computers in a local
network that connects through a router. There is not much more information
we can give, and as nobody in the forum appears to encounter the same
errors, we feel a little lost. A test shows that form 1200 operates more
reliable than 1001. The unfortunate aspect is that an application that
can no longer be opened, can also not be exported. It says "export complete",
but does not generate a file. How should we bring information to you to
have a closer look at the file?


Re: templates and drafts do not work after updates

Posted: Tue Aug 25, 2009 7:52 am
by Madu
Just another tip. EBL-initialized failed has also been know in the past to be as a result of
interference for antivirus/antispam products like ETrust or Norton for example. make sure
you have the latest updates for your anti virus prog. and that your filing suftware is in the
exception list. Just something else to look at.