XSL stylesheet error

Here you can post your opinions, ask questions and share information regarding the following services:
European Publication Server (EPO's official publication platform), EP Bulletin search and EP full-text search (Searching procedural data and the full text of EP A and B documents via the "Patent information services for experts" user interface).
Post Reply

thkadmin
Posts: 1
Joined: Sat Jun 18, 2016 12:40 am

XSL stylesheet error

Post by thkadmin » Sat Jun 18, 2016 12:58 am

Dear
I try to convert the XML file contained in the ZIP package of publication downloaded from EPO server.
I use Microsoft.XMLDOM object with your XSLT stylesheet
https://data.epo.org/publication-server ... patent.xsl
As a result I got the error message 80004005:
Named template 'add-rigth-zeros' does not exist in the stylesheet.
I actually found the file pat_com.xsl with link to nonexistent
add-rigth-zeros
template.
Would you care to explain this error, or - even better - fix probably faulty stylesheet pat_com.xsl ?
Thank you


EPO / EPAL Team
Posts: 139
Joined: Mon Dec 22, 2014 8:30 am

Re: XSL stylesheet error

Post by EPO / EPAL Team » Fri Jul 01, 2016 8:57 am

Dear User,

The faulty style sheet has been amended.
The XML conversion should work fine now.

Thanks for your feedback

Best regards,
epal team


samantha9276
Posts: 1
Joined: Wed Sep 19, 2018 7:25 am

Re: XSL stylesheet error

Post by samantha9276 » Mon Jan 14, 2019 6:42 am

Error with the sheets can you change it into the windows 10 software download for the advanced EP.


EPO / EPAL Team
Posts: 139
Joined: Mon Dec 22, 2014 8:30 am

Re: XSL stylesheet error

Post by EPO / EPAL Team » Mon Jan 14, 2019 7:40 pm

We are not sure to fully understand - could you please provide us with details on the issue?

Thank you for your cooperation

Patrick Le Gonidec


fdighera
Posts: 2
Joined: Mon Nov 27, 2023 3:03 pm

Re: XSL stylesheet error

Post by fdighera » Mon Nov 27, 2023 3:10 pm

Dear EPO team,

there seems to be an issue with the xsl file provided at this link: https://data.epo.org/publication-server ... patent.xsl
I have tried different validation methods, and always get this error:

Code: Select all

XMLSyntaxError: EntityRef: expecting ';', line 565, column 91
Am I doing something wrong?

Many thanks


EPO / EPAL Team
Posts: 139
Joined: Mon Dec 22, 2014 8:30 am

Re: XSL stylesheet error

Post by EPO / EPAL Team » Thu Nov 30, 2023 10:45 am

Dear fdighera,

we check the issue you reported and will answer asap

Best regards,

User support


EPO / EPAL Team
Posts: 139
Joined: Mon Dec 22, 2014 8:30 am

Re: XSL stylesheet error

Post by EPO / EPAL Team » Thu Dec 21, 2023 5:10 pm

Dear fdighera,

we did a validation test of https://data.epo.org/publication-server ... patent.xsl using XMLeditor and we do not reproduce your error

did you amend the XSL before validating it?

User support


fdighera
Posts: 2
Joined: Mon Nov 27, 2023 3:03 pm

Re: XSL stylesheet error

Post by fdighera » Wed Jan 10, 2024 10:56 am

Dear support team,

many thanks for your reply.
I've downloaded again the file and can confirm that it's working fine now.
It seems that the issue was due to a wrong encoding on my side.

Best regards


Post Reply