Having difficulties with Search API

This space is made available to users of Open Patent Services (OPS) web-service and now also to users of EPO’s raw data subscription products such as 14.7 DOCDB - worldwide bibliographic master database, 14.11 Worldwide legal status (INPADOC), 14.12 EP full text in XML, 14.1 EBD and more.

Users can ask each other questions, exchange experiences and solutions, post ideas. The moderator will use this space to announce changes or other relevant information.
Post Reply

langlotz
Posts: 4
Joined: Tue Jan 16, 2018 2:06 pm

Having difficulties with Search API

Post by langlotz » Wed Mar 21, 2018 8:25 am

Dear all

I'm trying to run an example for "Published Data Keywords Search with Variable Constituents" using the Developper's Area's OPS v3.2 API. I understand that one of the valid consituents would be "biblio", so I tried:

GET /3.2/rest-services/published-data/biblio/search?q=ti%3Dplastic HTTP/1.1

However, this results in a 404 Not Found error - an so do any other values for "{constituents}". Trying the same query for "Published Data Keywords Search without Consituents" works perfectly:

GET /3.2/rest-services/published-data/search?q=ti%3Dplastic HTTP/1.1

finds >10,000 results (<ops:biblio-search total-result-count="10000">).

What am I missing...?


EPO / OPS Support
Posts: 908
Joined: Thu Feb 22, 2007 5:32 pm

Re: Having difficulties with Search API

Post by EPO / OPS Support » Thu Mar 22, 2018 10:58 am

Hi,

There seems to be an issue with API console and we have already informed our developers.

Regards,

OPS support


Post Reply