Inconsistant search results?

This space is made available to users of Open Patent Services (OPS) web-service and now also to users of EPO’s bulk data subscription products such as 14. EPO worldwide bibliographic database (DOCDB), 14.11 EPO worldwide legal status database (INPADOC), 14.12 EP full text data, 14.1 EP bibliographic data (EBD)and more.

Users can ask each other questions, exchange experiences and solutions, post ideas. The moderator will use this space to announce changes or other relevant information.
Post Reply

tangopium
Posts: 4
Joined: Thu May 16, 2013 8:18 pm

Inconsistant search results?

Post by tangopium » Tue May 28, 2013 11:44 pm

Hi,

I was wondering if there is an error in your OPS search engine.

For example if I take the document RS49563
(published-data/publication/epodoc/RS49563/biblio):

Apparently it was published on 2007-04-10.

If I search now with the parameters pn=RS, pd=20070410, Range=1-100
(published-data/search/abstract,biblio,full-cycle?q=pn%3DRS%20and%20pd%3D20070410&Range=1-100) the mentioned document doesn't appear in the results.

On the other hand the last patent in the list was published on 2008-09-29
and not on 2007-04-10 as defined in the query.

As an additional hint I observed that when I searched with the same query some time ago I

1. Got 108 results - now there are just 80
2. The mentioned document RS49563 was listed but had another family-id (before: 43646340; now: 47739762).

Is the second point another error or are the family-ids changing?

Thanks in advance


EPO / OPS Support
Posts: 980
Joined: Thu Feb 22, 2007 5:32 pm

Re: Inconsistant search results?

Post by EPO / OPS Support » Mon Jun 03, 2013 1:13 pm

Dear user,

There are several issues addressed in you entry below. First of all, OPS as well as Espacenet are updated on daily basis so results can be different from day to day. Family ID can change, this is not static information.

And if you are using CQL search, you need to form your query like this:
http://ops.epo.org/3.0/rest-services/pu ... Range=1-40

You need to use first added publication date, which is date of RS (YU P at the time) A document and not the pd of B document. Please remember that OPS is not a database that follows logical procedures and rules, it is only a web service to access raw data products.

Best regards,
OPS support


tangopium
Posts: 4
Joined: Thu May 16, 2013 8:18 pm

Re: Inconsistant search results?

Post by tangopium » Mon Jun 03, 2013 3:01 pm

Dear OPS Team,

As you apparently changed the behavior of OPS during the last months, I wanted to ask if there is any chance that you undo this change, as it is now impossible to find newly published documents (which are not the first in their family).

You practically limit the search to A-kind documents. But a B-Kind document has a Publication Date as well. So why is the search now limited to the family while I'm supposed to search in single documents?

Kind regards

Andreas


EPO / OPS Support
Posts: 980
Joined: Thu Feb 22, 2007 5:32 pm

Re: Inconsistant search results?

Post by EPO / OPS Support » Mon Jun 03, 2013 6:02 pm

Dear user
This behaviour is not new at all. CQL search is the same as in Espacenet. If you try to search Espacenet you will get the same result. The system feeding OPS is designed so that allows only one publication date and that is the date of first added publication the system and in this case that was A publication.
At the moment we have no chance to change anything about the way how OPS or Espacenet work.

Kind regards,
OPS support


Post Reply